eXact iDip App Compatible Devices

Minimum Requirements: Bluetooth 4.0; iPhone, iPad, and iPod touch iOS system version 9.0 or later; Android version 4.4 or later

‚Äč